Elementor Widget Panel Not Loading

If your Elementor Widget Panel does not load and has the continuously spinning “Loading” icon, as shown in the image below, this is generally due to a resource issue, a conflict with another plugin, or a setting on your server that needs to be adjusted.

Please follow the steps below to troubleshoot and resolve this issue:

  1. Ensure you meet the system requirements. You can check if your system meets these requirements by going to Elementor > System Info. Two of the main things to check are the PHP version and memory limit, but also take note of any other items that might indicate a problem.
  2. Make sure you are using the most updated versions of Elementor, Elementor Pro (if you are using that), WordPress and your theme. Sometimes it isn't obvious that there is an update available. Go to Dashboard > Updates and click the Check Again button to be sure.
  3. Deactivate all of your plugins except Elementor and Elementor Pro. If this solves the problem, reactivate each plugin one by one, until you spot the problematic plugin. If found, contact that plugin's developers for help, or use a different plugin.
  4. Switch your theme (temporarily) to a default WordPress theme such as Twenty Seventeen to see if your theme is causing an issue. If so, contact the theme’s developers for help, or use a different theme.
  5. If the problem persists, ask your hosting company to provide you with ModSecurity error logs and resolve any problems from it. Also, ask your hosting company to make sure the PHP Zlib extension is enabled on your server.

If your entire Elementor screen will not load, rather than just the Widgets Panel not loading, please see the Can't Edit With Elementor guide instead.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.