Some elements disappeared on my live site, how can I solve this?

Generally, when some elements disappeared, this is due to a conflict with a plugin or with some script added via your theme.

This is what you can do to troubleshoot this:

  • Deactivate your plugins besides Elementor and Elementor Pro. If it solves the issue, reactivate them one by one.
  • Switch to a default WordPress theme such as Twenty Nineeen. It if helps, that means that there is some script added via your theme which is conflicting with the elements.
  • Make sure that you do not have mixed content. For instance, images or icons loaded via HTTP while your website uses the HTTPS protocol. To solve these mixed content issues, please consult this guide: https://docs.elementor.com/article/218-i-changed-the-url-of-my-website-and-elementor-does-not-work-anymore Mixed content can make your pictures and icons disappear.

Note: In Safari, if you are not seeing mouse effects, or you are experiencing the problem of elements disappearing in Safari, this is due to an old jQuery version being used by WordPress. In some cases, viewing Mouse Track effects via Safari might cause a jQuery error which will cause elements to disappear, such as missing carousel arrows, for example. If this happens, you may also see an error which references "maximum call stack size exceeded". To resolve the issue, either remove entrance animations from widgets with motion effects and/or remove mouse effects from areas that have both scrolling and mouse effects simultaneously activated.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.