My Site Is Working With WordPress 2.6, Will Elementor Work For Me?

No. 

Elementor supports WordPress 4.4 or greater, and is compatible with PHP 5.4 or greater.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.